Major incident

Major incident Picturepark DAM - CH02 Picturepark DAM - CH04 Picturepark DAM - CH03 Picturepark DAM - CH01
43 minutes, 40 seconds

Updates

Resolved

The issue has now been resolved. Apologies for any inconvenience.

April 29, 2020 · 10:33 CET
Issue

We are experiencing connectivity in our cloud environment. We are currently working on solving the problems.

April 29, 2020 · 09:58 CET

← Back