Issue currently under investigation

Major incident Picturepark DAM - CH01 Picturepark DAM - CH03 Picturepark DAM - CH04
2024-04-17 19:23 CEST · 48 minutes

Updates

Resolved

The issue has been resolved. We apologise for any inconvenience.

April 17, 2024 · 20:11 CEST
Issue

The platform is currently unavailable. We are currently investigating this and will update you here. Apologies for any inconvenience.

April 17, 2024 · 19:23 CEST

← Back