Issue currently under investigation

Minor incident Picturepark DAM - CH01 Picturepark DAM - CH02 Picturepark DAM - CH03 Picturepark DAM - CH04
2024-05-13 10:32 CEST · 10 hours, 28 minutes

Updates

Resolved

The issue has been resolved. We apologise for any inconvenience.

May 13, 2024 · 21:00 CEST
Issue

The platform is currently experiencing issues with some sent emails being rejected by end mail servers. We are currently investigating this and will update you here. Apologies for any inconvenience.

May 13, 2024 · 10:32 CEST

← Back