Decreased performance and availability

Major incident Picturepark DAM - CH02
2021-03-05 08:06 CEST · 1 hour, 36 minutes, 23 seconds

Updates

Resolved

The issue has now been resolved. Apologies for any inconvenience.

March 5, 2021 · 09:42 CEST
Investigating

We are currently experiencing issues with the platforms and are working on the problem

March 5, 2021 · 08:07 CEST

← Back