Unexpected downtime

Major incident Picturepark DAM - CH01 Picturepark DAM - CH02 Picturepark DAM - CH03 Picturepark DAM - CH04
2019-12-04 12:07 CEST · 57 minutes, 21 seconds

Updates

Resolved

The issues have been resolved. We apologize for any inconvenience caused and thank you for your understanding.

December 4, 2019 · 13:04 CEST
Investigating

We are having issues with our cloud platforms. We are working on the problem.

December 4, 2019 · 12:08 CEST

← Back