Unscheduled offtime

Major incident Picturepark DAM - CH01 Picturepark DAM - CH02 Picturepark DAM - CH03 Picturepark DAM - CH04
2020-01-16 21:00 CET · 1 hour, 9 minutes

Updates

Resolved

The issues have been resolved. We apologize for any inconvenience caused and thank you for your understanding.

November 4, 2021 · 16:24 CET
Investigating

We are currently experiencing a major outage and are working on a timely resolution. We will update this status as we gather further information. We apologize for any inconvenience caused and thank you for your understanding.

November 4, 2021 · 16:24 CET

← Back