Emergency Maintenance from 2020-01-29 10:00 CEST to 2020-01-29 11:00 CEST

Scheduled Maintenance Picturepark DAM - CH02 Picturepark DAM - CH04 Picturepark DAM - CH03 Picturepark DAM - CH01
1 hour

Update

Update

Maintenance has been extended a further 15min

January 29th, 2020 at 10:46 CEST
Update

Maintenance has been extended for another 15 min

January 29th, 2020 at 10:28 CEST
Scheduled

Emergency maintenance is scheduled for today. Picturepark may be partially unavailable during this time. Apologies for any inconvenience.

January 29th, 2020 at 08:13 CEST